Off-Road Forums & Discussion Groups - View Single Post - OT - Mazda 626 Wiper Delay
View Single Post
post #1 of (permalink) Old 01-02-2002, 02:48 PM
jeepfiend
Guest
 
Posts: n/a
OT - Mazda 626 Wiper Delay

I can't seem to find an answer for this, so I will try here, the source of all reason and knowledge in the universe[img]/wwwthreads_images/icons/tongue.gif[/img]. The other day I went out to start the little turd mazda, and unbeknownst to me, Jeepwife had left the wipers on delay. Of course the first thing any wiper does on delay when the ignition is turned on is run. Here comes the bad part, They were frozen quite solidly to the windshield. Now, delay no longer works, nor will the wipers return to the park position from any other speed setting. I called the Mazda dealer hoping to draw on their knowledge only to have my belief, that all dealership service employees are greedy morons, comfirmed. They guy could not tell me whether the delay function is controlled in the wiper motor or a seperate module. He did however offer to take $70/hour from me to track down the problem. I courteously told him to stuff it up his wazoo and told him I would check elsewhere. The really unfortunate part of the whole predicament is the fact that my wife loves this puke little car. Any info would be greatly appreciated, it is really annoying driving with wipers that don't park. Thanks in advance.

Cage Up, Wheels Down
Jeepfiend
All my Jeeps are in pieces! Except for one!!
 
 
 
For the best viewing experience please update your browser to Google Chrome