Off-Road Forums & Discussion Groups - View Single Post - vacuum advance question
View Single Post
post #1 of (permalink) Old 05-21-2005, 10:18 AM
**DONOTDELETE**
Guest
 
Posts: n/a
vacuum advance question

Hi all, been a long time. My 1979 CJ-7 has been revived with a engine transplant, and now we're in the long slow road to recovery. Now I'm stumped, and I am in need of some sage advice. Here's my problem:

almost two years ago, my CJ threw a rod through the cylinder wall and so I had to get a new 258. My money situation being what it was (still is), I bought a used 258 from a Jeep junkyard (1975 cj-5) and put it in there. I put my MC2100 back on it, along with a new-to-me Chevy HEI upgrade with all new guts except the vacuum advance (which I had checked with my patented precision suck-on-the-hose test). After much drama with other systems, I got it to start and stay running. However, it's straining to go 40 mph.

So I bought a vacuum pump and ran a few tests:

- tested the vacuum with the engine at idle using my timing light. The timing appeared to advance way too fast when I would increase RPMs (as in it idled at about 3 BTDC, and jumps quickly past 21 BTDC and off the charts).

- tested the vacuum advance diaphragm with the dist. cap off using the vacuum pump. It started moving a little before 5 in-Hg, and reached maximum movement at about 18. I tested a new diaphragm, and it maxed about 15.

-Tested the vacuum off the MC2100 at varied RPMs. I didn't have a tach hooked up, but I can tell you it sucked past 18 in-Hg at light throttle (approx 1500 RPM, but it's just a rough guess).

I figured that there was too much vacuum for it to go directly to the distributor, and the vacuum diagrams I found when I searched this site and looked here looked like a road map to parts I didn't know existed. I tried porting out of the top of the carb, under the air cleaner, but that's just open air behind the air filter, so no vacuum. I also tried porting it through the valve cover emission stuff, but that also is no vacuum.

I need to reduce the amount of vacuum my mc2100 is providing. I am using the ported vacuum at the base of the carb on the engine side (right under the choke assembly), and that's the only vacuum port I can find. It varies (a lot) under load, so I know it's not manifold vacuum. Anyone got any advice? Thanks for lookin'.
 
 
 
For the best viewing experience please update your browser to Google Chrome