rhino 2006 - Off-Road Forums & Discussion Groups
Yamaha UTV Forum The one that started the revolution - the Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-04-2006, 11:47 AM
onihr
Guest
 
Posts: n/a
rhino 2006

I am new on this site, but if someone can help me, I thank you.
Bought a rhino 2006 and have had trouble after 20 hours. It has been seen by 2 dealer services and they can't get to the trouble. Fuel pump and filters and plug has been changed.
Problem is, it can ride as long as 2 hrs. and then it dies and backfires. Sometimes it re-starts but does not go for long and stops again. Sometimes it goes a longer distance and with no warning just drops speed and then stops. Getting tired of being towed in.

Has anyone with a rhino have any advice, please and thanks.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome