No fire - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-08-2010, 01:15 PM Thread Starter
Newbie
 
Join Date: Feb 2010
Location: canada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
No fire

Hi there

Went off this weekend for a snowmobile trip and after 5 hours of driving my sled would'nt start. It is a 1998 700 triple grand touring. Tried just about everything but had no luck. There was no fire on the plugs and the battery wouldn't charge. I came home yesterday and had it in my heated garage overnight. Charged the battery and away it went. It seemed to run perfectly so I put everything else back together and guess what, it wouldn't start. No fire again. Just wondering if anybody has any suggestions.

Thanks
Curt
Penney Curtis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome