1992 Ski-doo Safari problem... - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-24-2004, 02:17 PM
wackey
Guest
 
Posts: n/a
1992 Ski-doo Safari problem...

I have an 1992 safari with an 377 engine, It is hard to start, when i get it started, It will work fine for about 5 mins and it will then run on 1 cylinder. The both carbs are clean, the fuel pump is redone,One of the cylinders are @ 90lbs and the other is @ 110lbs. This may be the cause but i don't know, that is why i am here [img]images/graemlins/frown.gif[/img] . Can someone please help me.

thnx
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome