Santa Fe 3751 Steam Locomotive "Ran Me Over" - Off-Road Forums & Discussion Groups
The NOT-Off-Road Lounge Talk any topic NOT related to Off-Road vehicles. ESTABLISHED COMMUNITY MEMBERS ONLY - NO SPAMMERS.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-20-2012, 01:56 PM Thread Starter
Apprentice
 
redrhino99's Avatar
 
Join Date: Nov 2011
Location: Apple Valley, CA
Posts: 53
Thanks: 0
Thanked 1 Time in 1 Post
 
Santa Fe 3751 Steam Locomotive "Ran Me Over"

Video of the historic 1927 Santa Fe 3751 steam locomotive running over my gopro.


Sponsors: Coors Light, Rockstar & UTV5150
redrhino99 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-07-2012, 11:16 AM Thread Starter
Apprentice
 
redrhino99's Avatar
 
Join Date: Nov 2011
Location: Apple Valley, CA
Posts: 53
Thanks: 0
Thanked 1 Time in 1 Post
 
That same day I recorded a newer BNSF Freight Train the same way running over my GoPro. Pretty cool.

https://www.youtube.com/watch?v=Rhxyx76Fc8M

Sponsors: Coors Light, Rockstar & UTV5150
redrhino99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome