Hey Everyone.... - Off-Road Forums & Discussion Groups
New Member Introductions All new members must first post in this section to activate account.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-11-2013, 01:50 AM Thread Starter
Newbie
 
Join Date: Oct 2013
Location: Oahu
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Hey Everyone....

I wanted to "re-introduce" myself as Tom/TXROCK to everyone here on Off-Road.com....many of you previously saw me posting as "GenRight Tom" and recently resigned due to full-time work obligations with the Army picking back up where I would not have been able to commit the work requirements for the GR role. There is a new GR media coordinator on board and will see him posting on here under GenRight Off Road.

I am a regular member here on the forum now so any posts you see from me are strictly from a personal perspective.

Tom
TXROCK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome