Why is my 1991 Z71 running like crud? - Off-Road Forums & Discussion Groups
Go Back   Off-Road Forums & Discussion Groups > Chevy and GM > GM Standard IFS Trucks & SUV's

GM Standard IFS Trucks & SUV's All discussion of full sized IFS Trucks, SUV's to include Suburban



Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2002, 02:34 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Default Why is my 1991 Z71 running like crud?

Hi all,
I have a stock 350 TBI in my 1991 Z71 and its running like crud after the engine warms up. I just replaced the cap,rotor,spark plugs,air filter and fuel filter and cleaned the TBI with throttle body cleaner but still it runs crummy when warmed up. Mainly it bogs down and hesitates a little when I give it some gas after warm up.

Do I need to clean or replace the fuel injectors? Maybe the O2 sensor is going bad? Any other ideas?

Thanks for any advice!

***3/7/02 update - I changed the O2 sensor this morning and the truck runs great, thanks for all the feedback folks!***
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-05-2002, 02:38 PM
A1980GMC's Avatar
Can't Get Enough
 
Join Date: Oct 2000
Location: McKinney, Texas
Posts: 1,293
Thanks: 0
Thanked 0 Times in 0 Posts
A1980GMC is an unknown quantity at this point
Default Re: Why is my 1991 Z71 running like crud?

I had the same problem once with my 92 Full-Size Blazer. I did all of what you said, and finally fixed it with a new distributor.

It used to feel like I would give the gas hard, like when trying to pass someone and it responded like, duh what? It would really respond at all very very sluggish.

I hope you get it fixed.

Ryan

1999 Suburban 6.5" Cepek Lift and 3" Body lift, 37x12.5x15 SSR's
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #3  
Old 03-05-2002, 02:54 PM
90K5's Avatar
Veteran
 
Join Date: Apr 2000
Location: Lubbock Texas
Posts: 1,545
Thanks: 0
Thanked 0 Times in 0 Posts
90K5 is an unknown quantity at this point
Default Re: Why is my 1991 Z71 running like crud?

timing, also check firing order.

90K5



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #4  
Old 03-05-2002, 11:50 PM
Keyboard Implanted
 
Join Date: Jan 2001
Location: Mountain Home Idaho
Posts: 4,219
Thanks: 0
Thanked 2 Times in 2 Posts
The_Kid is an unknown quantity at this point
Default Re: Why is my 1991 Z71 running like crud?

does it studder

check the gasket under the throttle body, while its idleing take that cleaner you used to clean out the tbi and spray it around the base of the tbi unit, if it hesitates stumbles trys to die, dies, or anything when you do this the gasket is sucking air and is causeing the problem

if its not anything mentiond here or the above replys then maybe checking to see that the Z71 sticker is still straight, would help [img]/wwwthreads_images/icons/wink.gif[/img] just jokeing

but yeah the TBI gaskets on these trucks go out all the time

Evan


trucks suck
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #5  
Old 03-06-2002, 12:12 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Default Re: Why is my 1991 Z71 running like crud?

I had a similar problem on my 94. It would bog down off the line and then slowly pick up as I gained momentum. My problem was a clogged catalytic converter.


[img]/wwwthreads_images/icons/wink.gif[/img]Somebody once said "Go Big" . . . Well we're goin' Full Size[img]/wwwthreads_images/icons/wink.gif[/img]
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #6  
Old 03-06-2002, 01:44 PM
NEO
Guest
 
Posts: n/a
Default Re: Why is my 1991 Z71 running like crud?

Hey Kid, if I have a scratch in my Z71 sticker, will that decrease my HP??? LOL

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #7  
Old 03-06-2002, 02:38 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Default Re: Why is my 1991 Z71 running like crud?

I had the same problem in my 89 Blazer. The timing was retarded slightly. The GM dealer was the only one who could time it right. It ran like a champ after that was fixed. Mine also ran better cold, and would bog down worse on incline's. Hope this helps.

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #8  
Old 03-06-2002, 02:41 PM
Keyboard Implanted
 
Join Date: Jan 2001
Location: Mountain Home Idaho
Posts: 4,219
Thanks: 0
Thanked 2 Times in 2 Posts
The_Kid is an unknown quantity at this point
Default Re: Why is my 1991 Z71 running like crud?

actually I think if you run that through brush enough it might come off and gain you HPs


trucks suck
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #9  
Old 03-06-2002, 03:03 PM
90K5's Avatar
Veteran
 
Join Date: Apr 2000
Location: Lubbock Texas
Posts: 1,545
Thanks: 0
Thanked 0 Times in 0 Posts
90K5 is an unknown quantity at this point
Default Re: Why is my 1991 Z71 running like crud?

Did this start after you replaced the cap, rotor, plugs, etc? If it did, I can almost guarantee you you either have a few wires out of order, or maybe the cap isn't on tight or something like that. Check all the stuff you fixed and make sure you did it right.

90K5



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #10  
Old 03-06-2002, 03:06 PM
BigBlueZ71
Guest
 
Posts: n/a
Default Re: Why is my 1991 Z71 running like crud?

Ditto, check your plug wires. two of my wires were shot and my truck was running like crap. Installed new MSD 8.5mm's and it still runs like a champ.


"CAPTAIN CHROME OF THE SPONGY IFS"
1994 Chevy Silverado 1500 Z-71
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -5. The time now is 05:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.2.0
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM