Help! 95 Blazer Vortec V6 idle problems - Off-Road Forums & Discussion Groups
Go Back   Off-Road Forums & Discussion Groups > Chevy and GM > GM Small Trucks & SUV's

GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's



Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2001, 04:53 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Default Help! 95 Blazer Vortec V6 idle problems

My 95 Blazer 4.3 Vortech V6 CPFI (63,000 miles) idles like crap, but runs fine when driving. I have replaced the fuel pump and regulator, Oxygen sensor, Idle Air Control Valve, as well as completed a tune up. The right bank of spark plugs were fouled out, leading me to believe the CPFI is leaking and in need of replacement. But before I dump this kind of money into this CPFI, I would like to know this is the problem. Does anyone have any ideas on this? Help is greatly appreciated.

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-07-2001, 10:01 PM
Enthusiast
 
Join Date: Jun 2000
Location: TN
Posts: 230
Thanks: 0
Thanked 0 Times in 0 Posts
Blazernut is an unknown quantity at this point
Default Re: Help! 95 Blazer Vortec V6 idle problems

It is very possible that the CPI is the problem. It doesn't make sense that it would only foul one bank of plugs. Another thing that can cause the idle problem is the EGR valve, they had a bad problem with plugging up, and we had to change lots of them at the dealer. I can't remember if they came out with an updated part or if we just used the same ones to replace them. If you know someone with a scanner, have them check the EGR position, it may not be closing all the way. Just a thought.
Blazernut

'91 S15 Jimmy 5.7L 4X4
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.2.0
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM