4 x 4 not working - Off-Road Forums & Discussion Groups
GM Small Trucks & SUV's All discussion of S-Class Trucks and SUV's

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-29-2007, 08:59 AM
Frank
Guest
 
Posts: n/a
4 x 4 not working

My 1999 Jimmy's 4 x 4 is not working. When I push the engage button on the dash both 4 hi and 4 lo blink a few times and goes back to 2 wd.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-30-2007, 11:56 PM
Newbie
 
Hanr3's Avatar
 
Join Date: Jun 2006
Location: Central Illinois
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 4 x 4 not working

See the other post in this forum to a link that wil help.
Hanr3 is offline  
post #3 of (permalink) Old 07-12-2010, 06:53 AM
Novice
 
Join Date: Jul 2010
Location: texas
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
 
truckboy's solution

It sounds like you have a short in the control module, or a shorted switch. This may not be too hard to trouble shoot yourself, if you purchase a repair manual. They can be bought at most auto parts stores for around $20, and have a full trouble shooting section. You can look this up, and see what it takes to test the control module and associated components.
Other than that, you may need to take it to a reputable transmission shop, preferably one that specializes in 4-wheel drive vehicles.
truckboy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome