Ranger power loss on hot days? - Off-Road Forums & Discussion Groups
Ford Ranger, Bronco II, Explorer Discussion of all Ford mini and mid-sized 4x4 vehicles to include the Ranger pickup, Bronco II and Explorer SUV's.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-18-2016, 09:00 PM Thread Starter
Can't Get Enough
 
SilentBob2's Avatar
 
Join Date: Oct 2002
Location: Noel MO. USA
Posts: 1,094
Thanks: 0
Thanked 4 Times in 4 Posts
 
Ranger power loss on hot days?

So my wife drives a 07 sport 3.0 on a rural mail route. Last summer it started acting up on hot days. She would stop at a box and start to pull away and blaw, no power then it would come back. Only on days over 90*. Never through a code but I tried trouble shooting. Checked fuel pressure and it was fine, replaced map sesor. Temps dropped and all was good. About a month ago I replaced the motor and when I done that I put new injectors, new coil pack, new plugs wires. Well it got hot last week and guess what? Talked to a few people and they said cats. Replaced them Tuesday, still does it. Still no codes so for the heck of it I changed the IAC and still done it. I know its a heat issue so today I through a tps and egr on it but havent had a chance to run it long enough to see. I have read many posts on other forums about this but no solutions. I'm tired of throwing parts at it but with no CEL what choice do you have.any ideas or anyone that may have found the solution?
SilentBob2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome